Summary

Summary

Property | Value
Report created | 02-Nov-2005 19:21
DBMS and version | Microsoft SQL Server [ 08.00.0760 ]
Server | TOSHIBA2
Database name | Northwind
User/Login |
Schema/Owner | dbo
Driver and version | SQLSRV32.DLL [ 03.85.1117 ]


Users

Users, 9 items

Login Name | Default DB | Language | is user
AdminAppUser | master | us_english | yes
AspUser | master | us_english | no
BUILTIN-Administrators | master | us_english | no
I.Shekalev | testDB | us_english | yes
IDD_Guest | DAFASQL | us_english | no
IDD_Reports | DAFASQL | us_english | yes
IDD_WebUser | DAFASQL | us_english | yes
fshopuser | Frameshop | us_english | yes
sa | master |  | yes

Database roles for login 'AdminAppUser', 4 items

Database | Roles
HCECG | public, db_owner
dbSite | public, db_owner
intranet | public, db_owner
jacob | public, db_owner

Database roles for login 'I.Shekalev', 10 items

Database | Roles
DAFASQL | public, db_owner
DTM-SALES | public, db_owner
Frameshop | public
Northwind | public
master | public
model | public
msdb | public
pubs | public
tempdb | public
testDB | public, db_owner

Database roles for login 'IDD_Reports', 1 item

Database | Roles
DAFASQL | public

Database roles for login 'IDD_WebUser', 1 item

Database | Roles
DAFASQL | public

Database roles for login 'fshopuser', 1 item

Database | Roles
Frameshop | public

Database roles for login 'sa', 6 items

Database | Roles
Northwind | public, db_owner
master | public, db_owner
model | public, db_owner
msdb | public, db_owner
pubs | public, db_owner
tempdb | public, db_owner


Roles

Roles, 10 items

Role Name | Members | Is App Role
public |  | No
db_owner | dbo | No
db_accessadmin |  | No
db_securityadmin |  | No
db_ddladmin |  | No
db_backupoperator |  | No
db_datareader |  | No
db_datawriter |  | No
db_denydatareader |  | No
db_denydatawriter |  | No

Permissions for role 'db_owner', 63 items

Permission
Add/drop to/from db_accessadmin
Add/drop to/from db_backupoperator
Add/drop to/from db_datareader
Add/drop to/from db_datawriter
Add/drop to/from db_ddladmin
Add/drop to/from db_denydatareader
Add/drop to/from db_denydatawriter
Add/drop to/from db_owner
Add/drop to/from db_securityadmin
All DDL but GRANT, REVOKE, DENY
BACKUP DATABASE
BACKUP LOG
CHECKPOINT
DELETE permission on any object
DENY
EXECUTE any procedure
GRANT
INSERT permission on any object
REFERENCES permission on any table
REVOKE
SELECT permission on any object
TRUNCATE TABLE
UPDATE permission on any object
dbcc checkalloc
dbcc checkdb
dbcc checkfilegroup
dbcc checkident
dbcc checktable
dbcc cleantable
dbcc dbreindex
dbcc proccache
dbcc show_statistics
dbcc showcontig
dbcc shrinkdatabase
dbcc shrinkfile
dbcc updateusage
sp_addalias
sp_addapprole
sp_addgroup
sp_addrole
sp_addrolemember
sp_approlepassword
sp_change_users_login
sp_changegroup
sp_changeobjectowner
sp_dbcmptlevel
sp_dboption (update)
sp_dropalias
sp_dropapprole
sp_dropgroup
sp_droprole
sp_droprolemember
sp_dropuser
sp_fulltext_catalog
sp_fulltext_column
sp_fulltext_database
sp_fulltext_table
sp_grantdbaccess
sp_recompile
sp_refreshview
sp_rename
sp_revokedbaccess
sp_tableoption

Permissions for role 'db_accessadmin', 5 items

Permission
sp_addalias
sp_dropalias
sp_dropuser
sp_grantdbaccess
sp_revokedbaccess

Permissions for role 'db_securityadmin', 14 items

Permission
DENY
GRANT
REVOKE
sp_addapprole
sp_addgroup
sp_addrole
sp_addrolemember
sp_approlepassword
sp_changegroup
sp_changeobjectowner
sp_dropapprole
sp_dropgroup
sp_droprole
sp_droprolemember

Permissions for role 'db_ddladmin', 12 items

Permission
All DDL but GRANT, REVOKE, DENY
REFERENCES permission on any table
TRUNCATE TABLE
dbcc cleantable
dbcc show_statistics
dbcc showcontig
sp_changeobjectowner
sp_fulltext_column
sp_fulltext_table
sp_recompile
sp_rename
sp_tableoption

Permissions for role 'db_backupoperator', 3 items

Permission
BACKUP DATABASE
BACKUP LOG
CHECKPOINT

Permissions for role 'db_datareader', 1 item

Permission
SELECT permission on any object

Permissions for role 'db_datawriter', 3 items

Permission
DELETE permission on any object
INSERT permission on any object
UPDATE permission on any object

Permissions for role 'db_denydatareader', 1 item

Permission
No SELECT permission on any object

Permissions for role 'db_denydatawriter', 3 items

Permission
No DELETE permission on any object
No INSERT permission on any object
No UPDATE permission on any object


ServerRoles

Server Roles, 8 items

Role Name
sysadmin
securityadmin
serveradmin
setupadmin
processadmin
diskadmin
dbcreator
bulkadmin

Permissions for server role 'sysadmin', 130 items

Permission
ALTER DATABASE
Add extended procedures
Add member to bulkadmin
Add member to dbcreator
Add member to diskadmin
Add member to processadmin
Add member to securityadmin
Add member to serveradmin
Add member to setupadmin
Add member to sysadmin
Add/drop to/from db_accessadmin
Add/drop to/from db_backupoperator
Add/drop to/from db_datareader
Add/drop to/from db_datawriter
Add/drop to/from db_ddladmin
Add/drop to/from db_denydatareader
Add/drop to/from db_denydatawriter
Add/drop to/from db_owner
Add/drop to/from db_securityadmin
Add/drop/configure linked servers
All DDL but GRANT, REVOKE, DENY
BACKUP DATABASE
BACKUP LOG
BULK INSERT
CHECKPOINT
CREATE DATABASE
Complete SETUSER SQL user
Constraints on System tables
Create indices on system tables
Create/delete/modify system tables
DBCC ShrinkDatabase
DBCC ShrinkFile
DELETE permission on any object
DENY
DISK INIT
DROP DATABASE
EXECUTE any procedure
Extend database
GRANT
Grant/deny/revoke CREATE DATABASE
INSERT permission on any object
KILL
Mark a stored procedure as startup
RECONFIGURE
REFERENCES permission on any table
RESTORE DATABASE
RESTORE LOG
REVOKE
Raiserror With Log
Read the error log
SELECT permission on any object
SHUTDOWN
TRUNCATE TABLE
UPDATE permission on any object
USE to a suspect database
dbcc change 'on' rules
dbcc checkalloc
dbcc checkdb
dbcc checkfilegroup
dbcc checkident
dbcc checktable
dbcc cleantable
dbcc dbreindex
dbcc dropcleanbuffers
dbcc freeproccache
dbcc inputbuffer
dbcc outputbuffer
dbcc pintable
dbcc proccache
dbcc setcpuweight
dbcc setioweight
dbcc show_statistics
dbcc showcontig
dbcc showoptweights
dbcc shrinkdatabase
dbcc shrinkfile
dbcc traceon/off
dbcc updateusage
sp_addalias
sp_addapprole
sp_addgroup
sp_addlinkedsrvlogin
sp_addlogin
sp_addrole
sp_addrolemember
sp_addumpdevice
sp_adduser
sp_altermessage
sp_approlepassword
sp_change_users_login
sp_changedbowner
sp_changegroup
sp_changeobjectowner
sp_configure
sp_dbcmptlevel
sp_dboption (update)
sp_dboption update part
sp_defaultdb
sp_defaultlanguage
sp_denylogin
sp_diskdefault
sp_dropalias
sp_dropapprole
sp_dropdevice
sp_dropgroup
sp_droplinkedsrvlogin
sp_droplogin
sp_dropremotelogin
sp_droprole
sp_droprolemember
sp_dropuser
sp_fulltext_catalog
sp_fulltext_column
sp_fulltext_database
sp_fulltext_service
sp_fulltext_table
sp_grantdbaccess
sp_grantlogin
sp_helplogins
sp_password
sp_recompile
sp_refreshview
sp_remoteoption
sp_remoteoption (update)
sp_rename
sp_renamedb
sp_revokedbaccess
sp_revokelogin
sp_tableoption
sp_updatestats

Permissions for server role 'securityadmin', 16 items

Permission
Add member to securityadmin
Grant/deny/revoke CREATE DATABASE
Read the error log
sp_addlinkedsrvlogin
sp_addlogin
sp_defaultdb
sp_defaultlanguage
sp_denylogin
sp_droplinkedsrvlogin
sp_droplogin
sp_dropremotelogin
sp_grantlogin
sp_helplogins
sp_password
sp_remoteoption (update)
sp_revokelogin

Permissions for server role 'serveradmin', 7 items

Permission
Add member to serveradmin
RECONFIGURE
SHUTDOWN
dbcc freeproccache
sp_configure
sp_fulltext_service
sp_tableoption

Permissions for server role 'setupadmin', 3 items

Permission
Add member to setupadmin
Add/drop/configure linked servers
Mark a stored procedure as startup

Permissions for server role 'processadmin', 2 items

Permission
Add member to processadmin
KILL

Permissions for server role 'diskadmin', 5 items

Permission
Add member to diskadmin
DISK INIT
sp_addumpdevice
sp_diskdefault
sp_dropdevice

Permissions for server role 'dbcreator', 8 items

Permission
ALTER DATABASE
Add member to dbcreator
CREATE DATABASE
DROP DATABASE
Extend database
RESTORE DATABASE
RESTORE LOG
sp_renamedb

Permissions for server role 'bulkadmin', 2 items

Permission
Add member to bulkadmin
BULK INSERT


Permissions

Permissions by Database Objects

Permissions for 'dbo.Categories' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.CustomerCustomerDemo' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.CustomerDemographics' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Customers' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.DESCRIP3' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.DESCRIP32' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.EmployeeTerritories' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Employees' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.MyValues' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Order Details' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Orders' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Products' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Region' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Shippers' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Suppliers' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Territories' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.TwoCols' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo._TimeS' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.dtproperties' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.test2' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.test_scr' (table), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Alphabetical list of products' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Category Sales for 1997' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Current Product List' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Customer and Suppliers by City' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Invoices' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Order Details Extended' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Order Subtotals' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Orders Qry' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Product Sales for 1997' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Products Above Average Price' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Products by Category' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Quarterly Orders' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Sales Totals by Amount' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Sales by Category' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Summary of Sales by Quarter' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.Summary of Sales by Year' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.qwe' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.sysconstraints' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES

Permissions for 'dbo.syssegments' (view), 5 items

Login Name | Acces right | Grantor | Grantable
dbo | DELETE | dbo | YES
dbo | INSERT | dbo | YES
dbo | REFERENCES | dbo | YES
dbo | SELECT | dbo | YES
dbo | UPDATE | dbo | YES


Table of Content

Table of Contents

  • Summary
  • Users
  • Roles
  • Server Roles
  • Permissions